当前位置:坤哥网-tool-IDEA 编译项目报错:Error:java: 无效的源发行版: 11

IDEA 编译项目报错:Error:java: 无效的源发行版: 11

2019/9/13 14:17:40 tool阅读(38) 评论(0)


在 IDEA 中编译项目,报错:

Information:java: Errors occurred while compiling module 'WebModuleTest'

Information:javac 1.8.0_181 was used to compile java sources

Information:2019/9/13 9:58 - Compilation completed with 1 error and 0 warnings in 1 s 362 ms

Error:java: 无效的源发行版: 11

37043ed5-04fc-48cd-89bb-5e26b70c08e4.png

为什么为出现这个错误呢?

这是因为项目的 jdk(Project SDK) 和项目的语言级别(Porject language level)不同导致。

如何解决?

打开,File->Project Structure:

0a5ee19c-e933-4b33-8a6c-a38e9be0cc91.png

在 Project 一栏中找到 Project language level,如果以上 jdk 1.8 则选择 8 即可。

3bd00207-01f1-4083-be64-96346d3384d6.png


(完)


分类: 编程工具 IDEA

发表评论 没有账号,注册评论